HindmanProblems.hpp File Reference

Plans for Maxima-generators related to Hindman problems (and generalisations) More...

Go to the source code of this file.

Detailed Description

Plans for Maxima-generators related to Hindman problems (and generalisations)

Improve generator names
  • The current names are rather unsystematic.
  • Also the notion of "degeneration" needs to be replaced by "injective" (appropriately).
  • DONE hindman2_nbfcsud(r,n) is for hindmani_r(2).
    1. This function should be called hindmani_a1k2_nbfcsud(r,n).
  • DONE hindman2d_nbfcsud(r,n) is for hindman_r(2).
    1. This function should be called hindman_a1k2_nbfcsud(r,n).
  • Shouldn't we have these functions just for general a? Then called hindman_k2_nbfcsud(a,r,n) and hindmani_k2_nbfcsud(a,r,n).
  • And likely we should just have hindman_nbfcsud(a,r,k,n) and hindmani_nbfcsud(a,r,k,n).
  • How to call the non-diagonal versions?
    1. Perhaps just using the suffix "nd".
    2. Perhaps after the (possible) "i".
  • DONE hindman2gen_fcs(a,n) is for hindmani_2^a(2).
    1. This function should be called hindmani_r2k2_ofcs(a,n).
    2. And also hindman_r2k2_ofcs(a,n) is needed.
  • There is also the non-diagonal versions, using a parameter tuple [k1,k2].
    1. Again, just using suffix "nd".
    2. So the functions should be called hindmannd_r2_fcs(a,k1,k2,n) and hindmanind_r2_fcs(a,k1,k2,n).
The notion of a "Hindman parameter tuple"
  • As we have it currently for van-der-Waerden numbers (see vanderwaerden_p in ComputerAlgebra/RamseyTheory/Lisp/VanderWaerden/Numbers.mac), we need the notion of a "Hindman parameter tuple".
  • Actually, we should centralise all such notions; likely in module ComputerAlgebra/RamseyTheory.
  • A "Hindman parameter tuple" should be a list [a,L], where a is a natural number >= 1, and L is a list of natural numbers >= 1, sorted in ascending order; but see below.
  • The parameter a (changing the starting number of the list of vertices) could, of course, be used also for vdW-problems etc.
    1. Do we need a general scheme?
    2. For the Hindman-problems perhaps the special motivation to consider this additional parameter was to get a handle on the otherwise too big numbers?
    3. So here we have special (historical) reasons to include parameter a.
    4. But for a general systematic exploration of the field of Ramsey theory likely this variation should also be applied to vdW-problems etc.
    5. Perhaps then those should be called tuples should be called "extended". And then we should also have Hindman parameter tuples L, and extended Hindman parameter tuples [a,L].
Write tests

Definition in file HindmanProblems.hpp.